1.9
[auf_django_saml.git] / doc / outils.rst
index 1474285..c17f514 100644 (file)
@@ -9,8 +9,10 @@ Ce paquet apporte :
 
     vous devez avoir le paquet *auf.django.references* d'installé.
 
 
     vous devez avoir le paquet *auf.django.references* d'installé.
 
-* un décorateur **employe_required**
 
 
+* un décorateur **employe_required**::
+
+    from auf.django.saml.decorators import employe_required
 
 .. versionadded:: 1.2
 
 
 .. versionadded:: 1.2
 
@@ -18,4 +20,19 @@ Ce paquet apporte :
 
     vous devez avoir le paquet *auf.django.references* d'installé.
 
 
     vous devez avoir le paquet *auf.django.references* d'installé.
 
-* une commande Django pour prépopuler les employés **bin/django employes import**
+* une commande Django pour prépopuler les employés **bin/django employes import**::
+
+    bin/django employes import
+
+
+.. versionadded:: 1.5
+
+
+* un décorateur **login_required**::
+
+    from auf.django.saml.decorators import login_required
+
+*  une réponse HTTP pour **rediriger vers la page de login**::
+
+    from auf.django.saml.views import redirect_to_login
+