Encore d'autres
authorMoussa NOMBRÉ <mnombre@u-nm.b.ca.auf>
Fri, 29 Jun 2012 16:50:05 +0000 (12:50 -0400)
committerMoussa NOMBRÉ <mnombre@u-nm.b.ca.auf>
Fri, 29 Jun 2012 16:50:05 +0000 (12:50 -0400)
commit8fe59a9332eb19a88c6e02291f6a2dbafcef969c
tree689a8583afdfe782593e301692ed905325573e0c
parent4d7fdb89006429add2133a320ac7f135a14172a1
Encore d'autres

I'm not a php expert, but a bit of googling told me that preg() doesn't exist. I tried preg_match() instead and it works ! --- http://www.joomfish.net/forum/viewtopic.php?f=47&t=8256
http://php.net/manual/fr/function.preg-match.php
http://ca.php.net/manual/fr/function.ereg.php

Le 2012-06-29 12:03, Marc Nachin a écrit :
> Merci Moussa pour ton aide,
>
> Malheuresement Lodel n'a pas de mise à jour pour php5. Cet outil est vraiment très peu utilisé, peu suivi et donc peu efficient.
> J'ai refais un commit en remplacant la fonction ereg par preg, mais ecran blanc, J'ai peut être fait une fausse manip.
>
> Après ci cela ne marche toujours pas, je ne saurai conseillé à Victorine de se tourner vers des vrais experts de lodel, car mes compétence et mon temps sont insuffisant.
> Cordialement.
>
> Marc.
>
> Le 12-06-29 16:51, Moussa NOMBRÉ a écrit :
>> Le 2012-06-29 10:28, Marc Nachin a écrit :
>>> Moussa,
>>>
>>> J'ai remis mon dépôt à neuf. et commiter pour cette erreur
>>>
>>> PHP Error (Warning) in file '/srv/www/bulletin.auf.org/lodel-0.9/scripts/nusoap.php' on line 270 :
>>> get_class() expects parameter 1 to be object, string given
>>>
>>> les modifs suivantes:
>>>
>>> -          (get_class($val) == 'servooattachment') ) {
>>> +          (gettype($val) == 'object' && get_class($val) == 'servooattachment') ) {
>>>
>>> et j'ai une erreur quand je veux puller sur le serveur:
>>> error: Your local changes to 'lodel-0.9/scripts/nusoap.php' would be overwritten by merge.  Aborting.
>>> Please, commit your changes or stash them before you can merge.
>> Voici ce qu'il faut faire dans ce cas :
>> git checkout HEAD lodel-0.9/scripts/nusoap.php
>>
>> Ensuite, tu refais ton pull :
>> git-web:~/bulletin.auf.org$ git pull
>> Updating 8481fff..a05bc79
>> Fast-forward
>>  lodel-0.9/scripts/nusoap.php |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>> git-web:~/bulletin.auf.org$
>>
>> Ne reste plus qu'à tester ;-)
>>
>>> De plus je ne suis vraiment pas sur de cette modification, mes connaissances techniques ne me permettent pas de savoir fixer correctement ces erreurs relatives au passage à php5.3
>> Il faudrait voir si lodel n'offre pas un outil de migration vers le php5.3 ; normalement ça devrait être le cas.
>> De mon côté, suis tout comme toi, très très limité, pour ne pas dire nul, en php.
>>
>> NM
>>
>>
>>
>>> Merci par avance pour votre aide.
>>>
>>>
>>> Le 12-06-29 14:18, Moussa NOMBRÉ a écrit :
>>>> Salut Marc,
>>>>
>>>> Le 2012-06-29 07:57, Marc Nachin a écrit :
>>>>> Salut Moussa,
>>>>>
>>>>> Bon Victorine a trouvé encore une erreur que je n'avais pas vu hier, qui doit découler de php5:
>>>>>
>>>>> PHP Error (Warning) in file '/srv/www/bulletin.auf.org/lodel-0.9/scripts/nusoap.php' on line 270 :
>>>>> get_class() expects parameter 1 to be object, string given
>>>> Heuuuu .... as-tu trouvé comment corriger ?
>>>> as-tu remis à neuf ta copie local du dépôt ?
>>>> Si oui, il te suffit d'apporter le correctif localement, de push-er puis pull-er côté serveur.
>>>>
>>>> Courage mon cher.
>>>>
>>>> NM
>>>>
>>>>
>>>>>
>>>>> Merci.
>>>>> Marc.
>>>>> --
>>>>>
>>>>> Marc NACHIN
>>>>> Chef de projet Web
>>>>> Agence universitaire de la Francophonie
>>>>> Tél : 33 (1) 44 41 42 98
>>>>> marc.nachin@auf.org
>>>>> auf.org - Actualités
>>>
>>>
>>> --
>>>
>>> Marc NACHIN
>>> Chef de projet Web
>>> Agence universitaire de la Francophonie
>>> Tél : 33 (1) 44 41 42 98
>>> marc.nachin@auf.org
>>> auf.org - Actualités
>>
>>
>
>
> --
>
> Marc NACHIN
> Chef de projet Web
> Agence universitaire de la Francophonie
> Tél : 33 (1) 44 41 42 98
> marc.nachin@auf.org
> auf.org - Actualités
lodel-0.9/scripts/nusoap.php