exclure des requirements les paquets inclus dans squeeze
authorPatrick Hetu <patrick.hetu@auf.org>
Tue, 4 Nov 2014 20:01:11 +0000 (15:01 -0500)
committerPatrick Hetu <patrick.hetu@auf.org>
Tue, 4 Nov 2014 20:01:11 +0000 (15:01 -0500)
Makefile
requirements/django_auf_common.txt
seeds/squeeze.txt

index 4395522..f30da96 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ all: $(TARGET)
 
 requirements/%.txt: seeds/%.txt
        mkdir -p requirements/
-       freeze-requirements freeze $< -m $@ --exclude django
+       freeze-requirements freeze $< -m $@ --exclude django --exclude-requirements seeds/squeeze.txt
 
 sdk/%: requirements/%.txt
        pip install -r $< -t $@ $(PIP_OPTIONS) --no-deps
index 72e27b8..f916670 100644 (file)
@@ -47,7 +47,7 @@ django-rq==0.7.0
 django-rq-dashboard==0.2.2
 django-selectable==0.9.0
 django-sendfile==0.3.6
-django-simple-captcha==0.4.2
+django-simple-captcha==0.4.3
 django-siteblocks==0.3.0
 django-sortable==0.3.1
 django-sorting==0.1
@@ -65,31 +65,25 @@ html5lib==0.999
 http-parser==0.8.3
 jinja2==2.7.3
 lepl==5.1.3
-lxml==3.4.0
 markdown2==2.3.0
 markupsafe==0.23
 nose==1.3.4
 ordereddict==1.1
 pillow==2.6.1
-pip==1.5.6
 polib==1.0.4
 psutil==2.1.3
 pygal==1.5.1
 pygments==1.6
-pygraphviz==1.2
 python-dateutil==2.2
 pytz==2014.9
-pyyaml==3.11
 raven==5.1.1
 redis==2.10.3
-reportlab==3.1.8
 requests==2.4.3
 restkit==4.2.2
 rfc6266==0.0.4
 rq==0.4.6
 rq-scheduler==0.5.0
 setuptools==7.0
-simplejson==3.6.5
 six==1.8.0
 socketpool==0.5.3
 sorl-thumbnail==11.12
index 361d8fb..70d8927 100644 (file)
@@ -1,14 +1,14 @@
-python-cairo==1.8.8
-python-egenix-mxdatetime==3.1.3
-python-egenix-mxtools==3.1.3
-python-imaging==1.1.7
-python-lxml==2.2.8
-python-mapnik2==2.0.0
-python-memcache==1.45
-python-mysqldb==1.2.2
-python-psycopg2==2.2.1
-python-pygraphviz==1.0
-python-reportlab==2.4
-python-simplejson==2.1.1
-python-yaml==3.09
+pycairo==1.8.8
+egenix-mxdatetime==3.1.3
+egenix-mxtools==3.1.3
+pil==1.1.7
+lxml==2.2.8
+mapnik2==2.0.0
+python-memcached==1.45
+mysqldb==1.2.2
+psycopg2==2.2.1
+pygraphviz==1.0
+reportlab==2.4
+simplejson==2.1.1
+pyyaml==3.09
 # python-dateutil==1.4.1